Tuesday, March 25, 2014

Anybus IPconfig tool can't find my AnybusX Gateway's IP Address

Hopefully this post will help you if you are having trouble finding the IP address of your Anybus X gateway. The MODBUS TCP Client Range of these gateways enable you to control a MODBUS TCP server and port that information to a whole host of different protocols such as PROFINET, PROFIBUS, DeviceNet, etc. 

When you get one of these units out of the box, you shouldn't have any problems searching for and configuring the gateway on your Ethernet network, but sometimes you are given a configuration that has been used in the plant already and now you need to make some changes. 

So what is your first step? Install and run the Anybus IPconfig tool (available on the Anybus website or on the the CD that comes with your unit). Assuming your physical Ethernet connection is intact, you should be able to scan the network for any HMS devices that are connected to the network. 

Tip: I would connect and Ethernet cable directly to the Gateway from the PC and disable the wireless card to avoid confusion later.

If you detect the device, you will be able to change the IP address from this tool, but I have some tips for you if don't detect anything:



Tip 1:
Click on the "Settings" button and make sure that you're not broadcasting from a specific Network interface controller - in fact, disable this tick box just to be safe. Click OK and try run the scan again. If you still don't detect anything, go to the next tip. 

Tip 2:
Click on the "Settings" button and attempt to scan for your device by enabling the internal DHCP server tick box. If you pick up a device now, my suggestion is to disable DHCP either through the IPconfig tool or though the web browser if your network does not require it. 

Note! make sure that your IPV4 LAN settings are in the same range as the gateway before attempting to browse to it.

Tip 3:
Sometimes you'll find that you still cannot see the device. This might be because someone has disabled the Anybus IPconfig (HICP) scan in the web interface and this can be tricky to fix. 


The problem is of course if you don't know the IP address and can't use the scan tool that you can't access the web interface to re-enable this setting. This is what I did to get around this: 

With only my Ethernet cable connected between the gateway and my PC, I ran a tool called Wireshark to monitor the traffic on my Ethernet interface card. Basically, I'm looking for any packets of information that look like that they can be coming for a gateway and in particular traffic that is coming from a device with a MAC address starting with 00:30:11. This is the reserved MAC address range for HMS Industrial Networks. You could use other similar software to achieve the same thing. I was lucky-  this message stood our right away because the gateway was sending out a broadcast ARP message:


Looking at the Sender IP I could work out where the message was coming from. I changed my LAN settings to be in the same range, connected via the web browser and re-enabled the scan via the Anybus IPconfig. 

Tip 4:
If you still don't come right, we can send a backup file that you can load onto an SD card. You insert the SD card into the unit and power up. This will reset your device to our default configuration and you will lose your mapping settings, but at least you will be able to scan for your device again. 



3 comments:

Jaco van Niekerk said...

Wireshark is an awesome tool! Thank You once again for assisting in finding the IP Address for an Anybus X-Gateway. Jaco.

Vigrx Plus said...

Thanks

Andrius said...

it is the same problem with all type devices with DHCP enabled. The root of cause is the normally you try to connect via switch or directly. I just tried new AB9006-B with scan results if connected without router. Wireshark shows IP of 0.0.0.0 in this case. as device can't get IP from DHCP server. There are pros and cons related to DHCP enabled.

Post a Comment